Cure Your Errors

Fix Windows Errors & Optimize Your System

Windows/Mac OS/Linux
Support Guide

Home

AddRequestObject has been deprecated while adding a resouce to a request

Hi Friends,
I have created a schedule task to create a request and to add users to it and also to provision a resource to the user. It is creating a request and adding a user successfully.
But while adding resource to the request by using the correct request key and object key, I am getting a compilation error.
This is the statment I am giving "requestIntf.addRequestObject(reqkey,objkey);"
I am getting the compilation error as "addRequestObkect(reqkey, objkey) in Thor.API.Operations.tcRequestOperationsIntf has been deprecated"
Did research in google but did not find anything. Can you please let me know what I am doing wrong.

Using API : - you can use tcFormInstanceOperationsIntf api method setProcessFormData
setProcessFormData
public void setProcessFormData(long plProcessInstanceKey,
java.util.Map phAttributeList)
throws Thor.API.Exceptions.tcAPIException,
Thor.API.Exceptions.tcInvalidValueException,
Thor.API.Exceptions.tcNotAtomicProcessException,
Thor.API.Exceptions.tcFormNotFoundException,
Thor.API.Exceptions.tcRequiredDataMissingException,
Thor.API.Exceptions.tcProcessNotFoundException,
tcAPIException
Sets the process data associated with an instance of a process in the system. If the process data already exists, then it updates the data with the specified values. In the case of a first-time save, all the required data must be provided. In the case of subsequent saves, only data being updated need be provided.
Parameters:
plProcessInstanceKey - The key of the process instance in the system.
phAttributeList - An array of tcMapping objects, each used to specify the attribute name-value pairs to be used to save data to the form
Throws:
tcAPIException - an error code of DOBJ.USR_PASSWORD_DOES_NOT_MATCH_POLICY might be set within this exception. If that's the case, one or many password policy rules were not met for password field in the form.
tcInvalidValueException
tcNotAtomicProcessException
tcFormNotFoundException
tcRequiredDataMissingException
tcProcessNotFoundException

Solution

1. Download & Run DLLEscort - Download Now

2. Click 'Start Scan' to analyze your System.

3. Click 'Fix Errors' and you're done!

 

Related Content

A_Player, A New Creative MediaSource Player S


A^b = n ,How to get the value for a ?


A\R Invoice. No matching record found


Azuretable.PullAsync() not syncing all records from azure db to local SQLite db.


Azure websites continues deployment using visual studio online doesn't work


Azure Webjobs with EF DB - A network-related or instance-specific error occurred while establishing a connection to SQL Server


AZURE The specified certificate could not be found in the LocalMachine certificate store,or the certificate does not have a private key.


Azure TechNet Guru Announced for June 2014


Azure Storage Blob error - AnonymousClientOtherError and AnonymousNetworkError (why cannot see images)


Azure Sql DB Export to Storage Container fails with "An error occurred while sending the request"


Azure Site to Site VPN with Cisco ASA 5505


Azure Rest API PUT Block Blob Returns "The specified resource does not exist" CORS


Azure remote App with Azure SQL Backend


Azure PHP SDK createBlobService() not working - fails at $httpClient = $this- httpClient() in ServicesBuilder.php


Azure Pack Windows Service Bus 1.1 wont start on Windows 8.1


Azure Notification Hub Package Missing for Windows Phone 8.1


Azure multiple site-to-site VPNs (dynamic gateway) with Cisco ASA devices


Azure MFA ADFS Adapter registration service account password


Azure Deployment Errror with IISConfigurator.exe 2.5


Azure Data Sync Log Take Too Much Time to Load


Hi Guys
In the last two days I have experienced a hijacking of my browser. I have opened a web page and there have been embedded links to "unauthorised advertising" on the pages. Worse, sometimes the links are hidden.
I fell victim to one of the hidden links. I was redirected to a page called "SID=" and I cannot close the web page. The intent of the page is to get my cell phone number and bill me for premium content. This is done under the guise of offering me a free iPad or iPhone and a silly questionnaire. The really annoying part is that I cannot close the web page. I had to pull the other pages out of the window before I could close the window that had the fraud advertising embedded in it.

Hi all,
I have an early 2008 MacBook, with 2GB RAM (PC2-5300 DDR2 667 MHZ) and a 2.4 GHZ processor.
Recently I've started to use my laptop alot more for my research, which involves a lot of computation work (and unfortunately necessitates a VM to run Windows applications). As such I feel I need to improve the performance of my machine, and I think increasing the RAM is the best move.
I'm not sure as to which RAM should I install though? The 4GB PC2-5300 DDR2 667MHZ? Or something else?
It's an expensive enough job so I'd love a bit of advice!
Thanks

Hi,
I've just replaced my imac and, for the moment, I have no printer with it, as the one I have [HP PSC 1400 series] is attached at my older imac. and not sopported by my new imac.  My new imac has os 10.9.3 maverick and I have to buy a new printer for it. I was thinking og buying the HP Photosmart 5520 e-All-in-One Wireless Printer  but I need to be sure that it is compatible with my machine and that I will not have problems of use.  Can anybody help?.
This question was solved.
View Solution.

A section within my site holds a lot of articles. I am re-designing the layout of just that sub-page similar to a blog page. Current articles on the opening page would show the first paragraph of about 4 articles, then the [more] link would follow each. The link would open the whole article in a new window/page. (I have a lib item on the right which holds the permenant links back to the start page for the articles, or further links to archives).
Right now I have archived articles saved and linked as pdf files that open into a _blank page. It works but a lot of time and labor to convert and re-link articles as pdf.
But I have seen this on a simple blog site where the article opens up on what looks like an identical but fresh page as html. This site has hundreds of articles and I can't imagine there is a separate dedicated page holding each article...?
If anyone understands what I'm describing... Is there a way to do this?
Thanks for any help! --Jeff

Hi,
I want to create a jni bridge in order to open a player in a java Frame. This player works fine in a mobile native application.
I want to know if somebody tried already to create such a bridge keeping in mind that this is for mobile environment. If yes, is there some specific problems which I should be aware of?
Specifically I have 2 problems.
1. My jni getHWND method always return 0.
JNIEXPORT jint JNICALL Java_JavaRMEngineInterface_getHWND
(JNIEnv *env, jobject obj, jobject component){
     HWND hWnd = 0;
//try {
typedef jboolean (JNICALL PJAWT_GETAWT)(JNIEnv, JAWT*);
JAWT awt;
JAWT_DrawingSurface* ds;
JAWT_DrawingSurfaceInfo* dsi;
JAWT_Win32DrawingSurfaceInfo* dsi_win;
jboolean result;
jint lock;
bstrt jawtPath = "\\Windows"; // Put Path String from jrePath to jawtPath
//Load AWT Library
if(!_hAWT)
//for Java 1.4
hAWT = LoadLibrary(jawtPath + bstr_t("\\jawt.dll"));
//if(!_hAWT)
//for Java 1.3
//_hAWT = LoadLibrary(jawtPath + bstrt("\\awt.dll"));
if(_hAWT)
PJAWT_GETAWT JAWT_GetAWT = (PJAWT_GETAWT)GetProcAddress(_hAWT, L"[email protected]");
if(JAWT_GetAWT)
awt.version = JAWT_VERSION_1_3; // Init here with JAWT_VERSION_1_3 or JAWT_VERSION_1_4
//Get AWT API Interface
result = JAWT_GetAWT(env, &awt);
if(result != JNI_FALSE)
ds = awt.GetDrawingSurface(env, component);
if(ds != NULL)
lock = ds->Lock(ds);
if((lock & JAWT_LOCK_ERROR) == 0)
dsi = ds->GetDrawingSurfaceInfo(ds);
if(dsi)
dsi_win = (JAWT_Win32DrawingSurfaceInfo*)dsi->platformInfo;
if(dsi_win)
hWnd = dsi_win->hwnd;
ds->FreeDrawingSurfaceInfo(dsi);
ds->Unlock(ds);
awt.FreeDrawingSurface(ds);
return (jint)hWnd;
//}catch()
return (jint)hWnd;
2. this second method throw an "error C2100 illegal indirection" at the last line on g_hwndMain.
JNIEXPORT jboolean JNICALL Java_JavaRMEngineInterface_construct
(JNIEnv *env, jobject obj, jlong peer, jint hwnd, jlong top, jlong left, jlong bottom, jlong right, jstring lpszSystemLanguage, jint nCacheSize){
     CRMEngineInterface cpp_obj = (CRMEngineInterface)peer;
     HWND g_hwndMain = (HWND)hwnd;
     HDC hDC = ::GetDC(g_hwndMain);
     SIZE size;
size.cx = (LONG) right - (LONG) left;
size.cy = (LONG) bottom - (LONG) top;
     TCHAR sInstallDir[MAX_PATH];
     ::GetModuleFileName(NULL, sInstallDir, MAX_PATH);
     TCHAR* pEndPath = _tcsrchr(sInstallDir, L'\\');
     if (pEndPath != NULL)
          *(pEndPath + 1) = 0;
     TCHAR sContentDir[MAX_PATH];
     memcpy(sContentDir, sInstallDir, MAX_PATH);
     UINT nCacheSizeCPP = (UINT) nCacheSize;
     return *cpp_obj->construct( hDC, g_hwndMain, size, sInstallDir, sContentDir, 0);
Any advice will be very helpful.

Hi,
Anyone have advice to fix this problem; iPhoto will not open on my MacBook Pro. The first time I had this problem was about a week ago, but previous problems.
This is what I have tried to far, all with no results:
Launching iPhoto with the Option key pressed
Launching iPhoto with the Option and Command keys pressed
Resinstalling Lion OS
Removing iPhoto-related com.apple files in /private/var/db/receipts - thanks for the posts Old Toad!
Removing and reinstalling iPhoto based on Terrence's kind advice here.
Any advice on what might work for me?
Thanks!
Here is the message I see when I try to launch the app:
Here's the info for iPhoto:
And here are the details from the error message:
Process:    
iPhoto [496]
Path:       
/Applications/iPhoto.app/Contents/MacOS/iPhoto
Identifier: 
com.apple.iPhoto
Version:    
9.1.1 (9.1.1)
Build Info: 
iPhotoProject-5270000~13
Code Type:  
X86 (Native)
Parent Process:  launchd [136]
Date/Time:  
2013-07-20 13:10:35.515 +0900
OS Version: 
Mac OS X 10.7.5 (11G63)
Report Version:  9
Interval Since Last Report:     
5723 sec
Crashes Since Last Report:      
8
Per-App Crashes Since Last Report:   3
Anonymous UUID:                 
D85B6ED9-F438-49B0-B892-29D74C810E29
Crashed Thread:  0
Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Application Specific Information:
dyld: launch, loading dependent libraries
Dyld Error Message:
  Library not loaded: /Library/Frameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow
  Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto
  Reason: no suitable image found.  Did find:
/Library/Frameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow: mach-o, but wrong architecture
/Library/Frameworks/iLifeSlideshow.framework/Versions/A/iLifeSlideshow: mach-o, but wrong architecture
Binary Images:
0x1000 -   0xf11ff7  com.apple.iPhoto (9.1.1 - 9.1.1) <4D03C8FF-BA05-D344-E3C1-A5471FE9CB09> /Applications/iPhoto.app/Contents/MacOS/iPhoto
0x108b000 -  0x10b2ff7  com.apple.iPhoto.Tellus (1.1 - 37) <E344FEA4-029C-074F-C980-F939AD6DAF04> /Applications/iPhoto.app/Contents/Frameworks/Tellus.framework/Versions/A/Tellus
0x10d1000 -  0x10e8ff7  com.apple.iLifeFaceRecognition (1.0 - 21) <AD53D7A2-F0B2-FF76-5C6D-C23B234AB50E> /Library/Frameworks/iLifeFaceRecognition.framework/Versions/A/iLifeFaceRecognit ion
0x10f7000 -  0x1123ffb  com.apple.DiscRecordingUI (6.0.4 - 6040.4.1) <20BF6CE7-0923-3302-BE45-4880FA8A958D> /System/Library/Frameworks/DiscRecordingUI.framework/Versions/A/DiscRecordingUI
0x113c000 -  0x113efff  com.apple.ExceptionHandling (1.5 - 10) <7C514CC4-7951-31CA-AEB3-D4AF49F44AE7> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling
0x1144000 -  0x1150ff3  com.apple.UpgradeChecker (1.0 - 1.1) <D3B95E56-67AB-A529-7886-09DDEF3610DA> /Applications/iPhoto.app/Contents/Frameworks/UpgradeChecker.framework/Versions/ A/UpgradeChecker
0x8f2d5000 - 0x8f2dfff7  com.apple.iphoto.AccountConfigurationPlugin (1.1 - 1) <1B962C66-FFB8-A844-E664-3B1CE57A6CCD> /Applications/iPhoto.app/Contents/Frameworks/AccountConfigurationPlugin.framewo rk/Versions/A/AccountConfigurationPlugin
0x8fdae000 - 0x8fdd7fff  com.apple.iPhoto.Tessera (1.1 - 37) <4706F5C2-0720-1557-4B68-3FAF8B24F845> /Applications/iPhoto.app/Contents/Frameworks/Tessera.framework/Versions/A/Tesse ra
0x8fe58000 - 0x8fe8aaa7  dyld (195.6 - ???) <60FD3471-A1D7-342E-99A7-3EDECDAEC6EC> /usr/lib/dyld
0x9029e000 - 0x902acfff  com.apple.opengl (1.8.1 - 1.8.1) <766AFB12-A2CB-3A55-B662-FC9FFCAE0008> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL
0x910b7000 - 0x910ffff7  com.apple.SystemConfiguration (1.11.3 - 1.11) <C8DE66D7-0880-3F5F-A4BA-215B52DEFC74> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration
0x9133b000 - 0x9133bff0  com.apple.ApplicationServices (41 - 41) <C48EF6B2-ABF9-35BD-A07A-A38EC0008294> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Application Services
0x91373000 - 0x914d6fff  com.apple.QTKit (7.7.1 - 2345) <9C619E5C-C89C-358A-B7DE-0966A3A57D06> /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit
0x924d0000 - 0x924defff  libz.1.dylib (1.2.5 - compatibility 1.0.0) <E73A4025-835C-3F73-9853-B08606E892DB> /usr/lib/libz.1.dylib
0x93452000 - 0x93452fff  com.apple.Carbon (153 - 153) <6CB9BB2F-2707-3B9D-8F3F-0BFEEDE96494> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x94486000 - 0x9449cfff  com.apple.iChat.InstantMessage (6.0.2 - 837) <BA53CE88-D89B-3C2C-BE59-5B747EF3EE7E> /System/Library/Frameworks/InstantMessage.framework/Versions/A/InstantMessage
0x94b4e000 - 0x94c2fff7  com.apple.DiscRecording (6.0.4 - 6040.4.1) <5841CEC8-6746-357E-9F0A-C0614320D153> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording
0x94c30000 - 0x94eb5fe3  com.apple.QuickTime (7.7.1 - 2345) <331CD162-1F00-3934-9F50-8883AF3746F7> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime
0x95f64000 - 0x95fe3ff7  com.apple.iLifeMediaBrowser (2.6.4 - 502.4.5) <5C10CC72-586E-3497-9873-A0ACFB6156C3> /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeM ediaBrowser
0x979be000 - 0x97b72ff3  libicucore.A.dylib (46.1.0 - compatibility 1.0.0) <4AFF6FC3-6283-3934-8EFC-CA227CA11164> /usr/lib/libicucore.A.dylib
0x97fee000 - 0x982bdffb  com.apple.security (7.0 - 55148.6) <8DF67BDD-C98F-3B7E-AC63-D468407FA82D> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x982c0000 - 0x983d7fe9  com.apple.WebKit (7534.57 - 7534.57.7) <85DAC34E-86A1-380F-B166-56630C9B0BD5> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
0x98540000 - 0x9857dff7  libcups.2.dylib (2.9.0 - compatibility 2.0.0) <007A1877-E981-3007-A8FA-9B179F4ED6D1> /usr/lib/libcups.2.dylib
0x98f59000 - 0x9920bff7  com.apple.AddressBook.framework (6.1.3 - 1091) <B8CC707C-6368-3CDD-BE38-D2335B7CC2DE> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook
0x994c7000 - 0x995d7fe7  libsqlite3.dylib (9.6.0 - compatibility 9.0.0) <34E1E3CC-7B6A-3B37-8D07-1258D11E16CB> /usr/lib/libsqlite3.dylib
0x99d1a000 - 0x99d1afff  com.apple.Cocoa (6.6 - ???) <5FAFE73E-6AF5-3D09-9191-0BDC8C6875CB> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x9aba9000 - 0x9aeb7fff  com.apple.MessageFramework (5.3 - 1283) <FAEC957B-FC52-3561-94FE-23AD1A776DBD> /System/Library/Frameworks/Message.framework/Versions/B/Message
0x9bce1000 - 0x9bce1fff  com.apple.Accelerate (1.7 - Accelerate 1.7) <4192CE7A-BCE0-3D3C-AAF7-6F1B3C607386> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x9be5a000 - 0x9c031fe7  com.apple.CoreFoundation (6.7.2 - 635.21) <4D1D2BAF-1332-32DF-A81B-7E79D4F0A6CB> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x9c053000 - 0x9c0b7fff  com.apple.framework.IOKit (2.0 - ???) <94827954-5906-36C4-819B-24CDAFD85C72> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x9ce75000 - 0x9ce75ff2  com.apple.CoreServices (53 - 53) <7CB7AA95-D5A7-366A-BB8A-035AA9E582F8> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

Under Lion my 2010 (HDD) Macbook Air has been intolerably slow. It could take 10 minutes to start a program. When connecting to a projector, it could likewise take 10 minutes for it to resize windows during which it was unresponsive. I have been about to hurl it in the trashcan because this computer was just such an impediment to my work. But now I found the solution: don't run Safari. I had long suspected 2G ram combined with a slow HDD was the culprit. I tried to minimize the number of programs open, but let Safari run permanently. But it turns out Safari uses enormeous amounts of memory, and it has a tendency to just grow and grow its memory grab. Now, I quit Safari when I want to run other programs, and after this the computer is merely slow, not intollerably so. It is annoying to always have to quit Safari, but at least it makes the computer useful.
Any better suggestions than always quitting Safari?

Hi everybody - opinions welcomed please.
I currently run 2 x Pro 9000 Mk IIs and 1 x HP Designjet Z2100 44" (this runs exactly the same ink and printheads as the HP B9180 but a lot bigger).
I do a lot of printing for design and art students from the local university. Their work usually consists of a mixture of flat pale colour/grey, vivid photos, bad photos, design graphics, text .. everything on one A3 page .. many hundreds of different pages in their busy times. Predominantly on smooth white matte photo paper. 
I mainly use the 9000s for these but have always struggled with the 'magenta warm' appearance of the prints, especially on pale grey backgrounds and yellows. I experimented with many papers and have heeded the huge amount of advice on the 9000 being too warm, but have decided that I need to change.
For pure greyscale, I always use the Z2100 which is beautifully neutral, but it struggles a bit when it comes to some colours not 'popping'. It is also very slow and laborious to load single sheets.
Reading around the subject, the Pro 100 looks to have similar warm issues.
The Epson 3000 is an option, but am running very scared of clogging and wasted ink on swapping matte and photo papers.
So, for mainly but not always matte photo paper, would I be better served by the Pro 10 or maybe Pro 1? Quality-wise, the Pro 10 would definitely suffice. My concerns being that 1) The prints may still be a bit warm 2) The pigment ink would be rather dull on matte paper.
I so SO wish that HP had upgraded the B9180 with a better range of colours, similar to the Z3200!
Gentlepeople of Canon - I do hope you are noting this.
Many thanks in advance .....

I really want to be able to connect video recorder to imac and be able to edit footage and make more presentable then burn DVDs. What cables and or software do I need????
Any help appreciated
thanks

Hello there,
I am relatively new to Microsoft T-SQL and I was wondering if someone could help shed some light into a requirement I got...
I have two tables in a database. One with accounts, and another with activities for such accounts. He is a simple diagram:
*NOTE: Dates are in the DD/MM/YYYY format.
Here is what I need to do:
I need to get a list of all the accounts where the LAST activity was created in a date range, along with a count of activities that fall in such range. The idea behind this is to find out accounts with no activity after a certain period.
I can certainly accounts with activities in a given range -- but that does not mean that there was no activities after the range.
For example, if I look for Accounts with activities between Feb/2014 and Mar/2014, this query should NOT return the Contoso account, because it ha an activity after Mar/2014 (i.e.: Meeting with John on 15/Apr/14).
Another example: If I query accounts with activities from 01/Jan/2014 and 03/Apr/2014, it should ONLY return the Adventureworks account:
Adventureworks (3)
[the number in parenthesis is the count of activities in that given time]
This is because all other accounts had activities after 03/Apr/2014.
Could someone please advise the best way to construct this query?
Thanks in advance for the help!
Regards,
P.